wxsk.net
当前位置:首页 >> tomCAt8 jDk版本 >>

tomCAt8 jDk版本

7 and later

7 and later(来之官方文档):

有关系的。 比如tomcat7,对应的jdk就是1.7。tomcat8,对应的就是jdk1.8 依次类推

明显是class文件不兼容导致的,你用的哪个版本的jdk? 官方有说明的: Tomcat 8.0 requires Java SE 7 or later. Read the RELEASE-NOTES and the RUNNING.txt file in the distribution for more details.

tomcat9支持:jdk8(含)以下版本; tomcat8支持:jdk7(含)以下版本; tomcat7支持:jdk6(含)以下版本; 你根据自己的环境来选择。

tomcat用的就是环境配置中的JAVA_HOME;可以选择在环境变量中查看;也可以查看tomcat的bin目录下的version.bat文件 使用version.bat文件查看jdk版本请参考https://jingyan.baidu.com/article/e2284b2b699ff7e2e6118d0c.html

不是必须的,但是要注意: java是向下兼容的 JDK,eclipse,tomcat的位数与系统位数最好一致 Eclipse 是一个开放源代码的、基于Java的可扩展开发平台。就其本身而言,它只是一个框架和一组服务,用于通过插件组件构建开发环境。幸运的是,Eclips...

不是什么版本的tomcat都可以用的。最好用tomcat6 tomcat8对jdk就有要求,tomcat8明确要求要用jdk7orlater

tomcat的启动rub.bat修改java_home路径啊,到里面 set /p java_home,写死了,然后就可以了,tomcat8才支持jdk7呢,其他都是别的。 太简单了

比如tomcat7,对应的jdk就是1.7。tomcat8,对应的就是jdk1.8 依次类推

网站首页 | 网站地图
All rights reserved Powered by www.wxsk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com